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Introduction
Your email signature is one of the most viewed pieces of content you'll ever create. It appears
at the bottom of every email you send, yet most of us settle for something basic or outdated
because designing a professional HTML signature is tedious, time-consuming work.

HTML email is notoriously fiddly. The quirks of Outlook rendering, the inconsistencies across
email clients, the table-based layouts that feel like coding in 2005... it's not complex work, but
it is frustrating, repetitive work.

That's exactly the kind of work AI handles brilliantly. Whether you're comfortable with code but
short on time, or you've never touched HTML in your life, Claude can act as your coding
partner. You stay in the creative driving seat, making design decisions. Claude handles the
grunt work.

What You'll Need Before You Start
Gather these elements before you begin:

• Your logo (hosted online, or ready to upload to your website)

• Your brand colours (hex codes like #C49C6A)

• Your contact details (phone, email, location)

• Links to your website and social profiles

• Any tagline or job title you want to include

• Access to Claude (claude.ai)

• A text editor (Notepad on Windows, TextEdit on Mac, or any code editor)

Tip: If your logo is on your website, right-click it and select 'Copy image address' to get the
URL.

Getting Your Images Online
For your signature to work properly, all images (logo, social icons, buttons) need to be hosted
online with public URLs. Recipients can't see images stored on your computer. This is also
beneficial because when you update the hosted image file, every email signature
automatically shows the new version without any editing required.

Option 1: Upload to Your Website

If you have a website, this is usually the best approach:

Squarespace users:

• Go to Website > Asset Library

• Upload your logo

• Click the three dots on your uploaded file and select "File Details"



• Right-click the image and open it in a new tab, then copy the URL

• Share this URL with Claude

WordPress users:

• Go to Media > Add New

• Upload your logo

• Click the uploaded image and copy the "File URL" from the right sidebar

Other website builders: Look for an "Assets" or "Files" section where you can upload
images and get a public URL.

Option 2: Google Drive

• Upload your image to Google Drive

• Right-click the file > Share

• Change access to "Anyone with the link"

• Click "Copy link"

• The URL will look like: https://drive.google.com/file/d/[FILE_ID]/view

• Transform it to: https://drive.google.com/uc?export=view&id;=[FILE_ID]

• Share this modified URL with Claude

Option 3: Image Hosting Services

Free services like Imgur, ImgBB, or Postimages let you upload images and get direct links.
Simply upload your image and copy the "direct link" or "HTML embed code" URL.

Testing Your Image URL

Before giving it to Claude, paste the URL directly into your browser's address bar. If the image
displays on its own (not as a download), the URL is correct.

Important: The URL must start with https:// (not http://) and point directly to the image file, not
to a page containing the image.

Choose Your Path
This guide covers three different starting points. Choose the one that matches your situation:

Path A: Updating an existing Outlook signature

You already have a signature in Outlook and want to redesign it.

Path B: Creating a new Outlook signature from scratch

You use Outlook but don't have an existing signature, or want to start fresh.

Path C: Gmail or other email clients



You don't use Outlook, or want to create a signature you can use anywhere.



Path A: Updating an Existing Outlook Signature
Step 1: Locate Your Signature File

Outlook stores your signatures as HTML files on your computer. You'll edit this file directly.

1. Open File Explorer on Windows

2. In the address bar, paste: %APPDATA%\Microsoft\Signatures

3. Press Enter

4. Find the .htm file with your signature name (e.g., 'My Signature.htm')

Tip: On Mac, signatures are stored in: ~/Library/Group
Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/Main Profile/Data/Signatures

Step 2: Set Up Your Preview Workflow

You'll work with two windows side by side: a browser to preview, and a text editor to make
changes.

1. Double-click the .htm file to open it in your web browser - this is your preview

2. Right-click the same .htm file and choose 'Open with' > Notepad (Windows) or TextEdit
(Mac)

3. Arrange both windows so you can see them side by side

Important for Mac users: TextEdit defaults to Rich Text format, which will corrupt your
HTML. Before editing the file, go to Format > Make Plain Text in TextEdit's menu. Without this
step, your code will be damaged.

Step 3: Work with Claude

Now you're ready to collaborate with Claude. Copy your existing HTML from the text editor
and share it:

"Here's my current email signature HTML [paste your code]. I want to
update

it with my new brand colours [your colours] and modernise the layout. Can

you help me redesign it?"

Step 4: The Iterative Loop

This is where the magic happens. You'll repeat this cycle until you're happy with the result:

1. Claude generates updated HTML

2. Select all the HTML code Claude provides and copy it

3. In your text editor, select all (Ctrl+A / Cmd+A) and paste (Ctrl+V / Cmd+V) to replace



4. Save the file (Ctrl+S / Cmd+S)

5. Switch to your browser and refresh (F5 or Ctrl+R / Cmd+R)

6. Review the result and tell Claude what to adjust

7. Repeat until perfect

Tip: Be specific with feedback. Instead of 'make it better', say 'reduce the logo width to 180px'
or 'add more space between the buttons'.

Step 5: Check in Outlook

Once you're happy with the preview in your browser, open Outlook. Your updated signature
should already be there, ready to use. Compose a test email to yourself to see how it looks
when sent.



Path B: Creating a New Outlook Signature from Scratch
Step 1: Create a Placeholder Signature

First, we need Outlook to create the signature file for us:

1. In Outlook, go to File > Options > Mail > Signatures (Windows) or Outlook >
Preferences > Signatures (Mac)

2. Click 'New' and give your signature a name (e.g., 'Main Signature')

3. Type anything in the editor - even just 'placeholder'

4. Click OK to save

Step 2: Locate the New File

Outlook has now created an HTML file for your signature:

1. Open File Explorer

2. Paste in the address bar: %APPDATA%\Microsoft\Signatures

3. Find the .htm file with your new signature name

Step 3: Set Up and Iterate

Now follow the same process as Path A:

1. Open the .htm file in your browser for preview

2. Open the same file in a text editor

3. Ask Claude to create a signature from scratch with your requirements

4. Paste Claude's HTML into the text editor, save, and refresh browser

5. Iterate until perfect

6. Open Outlook - your signature is ready

Mac users: Remember to set TextEdit to Format > Make Plain Text before editing your HTML
file.

Starting prompt:

"Help me create a professional HTML email signature. My brand colours are

[colours]. I want [describe layout]. My logo is at [URL]. Include: [your
details]."



Path C: Gmail or Other Email Clients
If you don't use Outlook, or want a signature you can paste into any email client, follow this
path.

Step 1: Get Your HTML File from Claude

Ask Claude to create your signature and save it as a downloadable HTML file:

"Help me create a professional HTML email signature. My brand colours are

[colours]. I want [describe layout]. My logo is at [URL]. Include: [your

details]. Please save it as an HTML file I can download."

Step 2: Set Up Your Preview Workflow

• Download the HTML file Claude creates

• Save it somewhere easy to find (e.g., your Desktop or Documents folder)

• Double-click to open it in your browser - this is your preview

• Right-click the file and open it in a text editor (Notepad, TextEdit, or VS Code)

Mac users: Set TextEdit to Format > Make Plain Text before editing the HTML file, or your
code will be corrupted.

Step 3: Iterate with Claude

Use the same iterative loop as the Outlook paths:

• Review the preview in your browser

• Tell Claude what to change

• Copy Claude's updated HTML

• Paste into text editor, replacing all existing content

• Save the file

• Refresh browser to see changes

• Repeat until perfect

Step 4: Install in Gmail

• Open your final HTML file in the browser

• Press Ctrl+A (Cmd+A on Mac) to select everything visible

• Press Ctrl+C (Cmd+C) to copy

• In Gmail, click the gear icon > 'See all settings'

• Scroll to the 'Signature' section



• Click 'Create new' and name your signature

• Click in the editor and press Ctrl+V (Cmd+V) to paste

• Scroll down and click 'Save Changes'

Tip: This copy-paste method works for most email clients, not just Gmail. The key is selecting
the rendered preview in your browser, not the raw HTML code.

Managing Multiple Signatures in Outlook
If you maintain multiple signatures for different purposes (e.g., a full signature for new emails
and a shorter one for replies), here's how to manage them:

Setting Your Default Signatures

• Go to File > Options > Mail > Signatures

• In the 'Choose default signature' section, select which signature to use for new
messages

• Select which signature (or none) to use for replies/forwards

Tip: Many professionals prefer a shorter signature for replies without the logo and full details,
as recipients already have your information from the initial email.

Updating a Specific Signature

When you have multiple signatures, locate the specific .htm file in your Signatures folder that
corresponds to the signature you want to update. The filename will match the signature name
you gave it in Outlook.



Working with Claude: Tips for Better Results
Be Specific Upfront

The more detail you provide initially, the closer the first draft will be:

• Your exact brand colours (hex codes)

• Layout preference (single column, two column, with border, etc.)

• What information to include

• Links to any hosted images (logo, icons)

• Any signatures you admire as reference

Give Clear Feedback

When iterating, specific feedback gets better results:

• "The logo is too big - try 180px width"

• "Add more space between the buttons and the social icons"

• "The newsletter button needs to match the width of the website button"

• "Can we try outline-style buttons instead of solid?"

• "The borders are getting cut off in Outlook - can you add padding?"

Test in Your Actual Email Client

The browser preview is useful for quick iterations, but always test in your actual email client.
What looks perfect in Chrome might render differently in Outlook or Gmail. Send test emails to
yourself.

When Things Don't Render Correctly

Email clients are notoriously inconsistent. If something breaks, tell Claude exactly what's
happening:

"The signature looks perfect in my browser but the button borders are cut

off on the left and right in Outlook. Can you adjust the HTML to fix
this?"

Claude can try different approaches: table-based layouts, image buttons, additional padding,
or other workarounds that render more reliably across clients.



Design Considerations
Layout

Single column layouts are simple and clean. Two-column layouts let you put contact info on
one side and buttons or social links on the other. Adding a subtle border or background colour
can make the whole thing feel more polished and contained.

Typography

Stick to web-safe fonts like Arial, Helvetica, or Georgia. If you specify a custom font, ask
Claude to include fallbacks for email clients that won't have it installed.

Colours

Use your brand colours sparingly. A common approach: one accent colour for your name or
key elements, and neutral greys for body text. Too many colours looks cluttered and
unprofessional.

Buttons

HTML/CSS buttons can be inconsistent across email clients. If you want buttons that look
exactly the same everywhere, ask Claude to create button images you can upload to your
website. This guarantees consistent rendering.

Social Icons

Keep icons small (20-24px) and visually muted. Bright, full-colour social icons can overwhelm
a signature. Consider monochrome versions or reducing the opacity.

Images and Hosting

All images (logo, icons, buttons) must be hosted online with public URLs. If images use local
file paths, they'll appear as attachments or broken images for recipients. Upload to your
website, Google Drive (with public sharing), or an image hosting service. Always use https://
URLs.

Mobile Rendering

A significant portion of your recipients will view your email on mobile devices. Keep these
mobile considerations in mind:

• Keep the signature width under 600px for comfortable mobile viewing

• Use a single-column layout or a layout that stacks well on narrow screens

• Ensure text is at least 14px so it's readable without zooming

• Make buttons and links large enough to tap easily (minimum 44px height)

• Test your signature on your own phone before finalising

If you want Claude to optimise your signature for mobile viewing, mention this in your initial
prompt or feedback.



What Good Looks Like
A successful email signature achieves these qualities:

• Professional and polished without being overdesigned

• Renders consistently across major email clients (Outlook, Gmail, Apple Mail)

• Readable on both desktop and mobile devices

• Contains all essential information without feeling cluttered

• Reflects your brand identity through colours and typography

• All links work correctly and all images load properly

• Maintains visual hierarchy with appropriate spacing and sizing



Troubleshooting Common Issues
Images Appearing as Attachments

This happens when images use local file paths instead of web URLs. Check that all image src
attributes start with https:// and point to publicly accessible URLs.

Unwanted Underlines on Links

Some email clients ignore text-decoration: none. Ask Claude to wrap link text in a span with
additional styling, or switch to image buttons which avoid this issue entirely.

Buttons Rendering at Different Widths

CSS width on links is unreliable across email clients. Ask Claude to use table-based buttons
with fixed width attributes, or create image buttons for guaranteed consistency.

Borders Getting Clipped

Add padding around bordered elements. Tell Claude to add padding-left and padding-right to
the table cells containing bordered items.

Rounded Corners Not Showing

Border-radius doesn't work in older Outlook versions (which use Word's rendering engine).
Your signature will have square corners for some recipients. This is a known limitation.

Signature Looks Different in Outlook vs Browser

Outlook uses Word's rendering engine, not a browser engine, so CSS support is limited.
Always test in Outlook before finalising. If something breaks, tell Claude and ask for an
Outlook-compatible approach.

Final Tips
• Test by sending emails to yourself from different accounts

• Keep it concise - recipients don't need your life story

• Update your signature when your branding or contact details change

• Consider a shorter version for replies (without the logo)

• Save your final HTML file somewhere safe for future updates

• If you change your hosted images, the signature updates automatically everywhere
without any editing required

Questions? Get in touch at info@sophiesbureau.com or visit sophiesbureau.com


